Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 25, 2018 - 09:11 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 5 months ago. Oct 25, 2018 - 08:47 AEDT