Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 12 days ago. Mar 13, 2019 - 14:59 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 12 days ago. Mar 13, 2019 - 14:27 AEDT