Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 15, 2019 - 17:57 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 2 months ago. Jan 15, 2019 - 17:53 AEDT