Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 6 months ago. Oct 04, 2018 - 17:21 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 6 months ago. Oct 04, 2018 - 17:09 AEST