Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 05, 2018 - 20:03 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 8 months ago. Oct 05, 2018 - 17:29 AEST