Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 02, 2019 - 04:16 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 4 months ago. Feb 02, 2019 - 00:33 AEDT