Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 19, 2019 - 01:21 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted about 1 month ago. Jun 18, 2019 - 23:59 AEST