Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 15, 2018 - 17:40 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 7 months ago. Oct 15, 2018 - 15:18 AEDT