Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 11 months ago. Jul 07, 2018 - 13:02 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 11 months ago. Jul 07, 2018 - 12:51 AEST