Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 14, 2019 - 21:55 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 2 months ago. Jun 14, 2019 - 21:39 AEST