Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 25 days ago. May 23, 2019 - 10:32 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 25 days ago. May 23, 2019 - 09:58 AEST