Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 27 days ago. Jun 26, 2019 - 23:45 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 27 days ago. Jun 26, 2019 - 23:22 AEST