Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 11 months ago. Jul 22, 2018 - 07:03 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 11 months ago. Jul 22, 2018 - 03:03 AEST