Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 25, 2019 - 05:49 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 3 months ago. Jun 25, 2019 - 05:40 AEST