Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 13, 2019 - 08:54 AEDT
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 5 months ago. Mar 13, 2019 - 08:45 AEDT