Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 17 days ago. May 30, 2019 - 22:06 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 17 days ago. May 30, 2019 - 21:48 AEST