Elevated Order Errors
Incident Report for Hey You
Resolved
This incident has been resolved.
Posted 5 months ago. May 30, 2019 - 22:33 AEST
Investigating
We're experiencing an elevated level of order submission/acceptance errors and are currently looking into the issue.
Posted 5 months ago. May 30, 2019 - 22:18 AEST